<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="pingback" href="https://www.springhappenings.com/xmlrpc.php" />
<meta property="og:type" content="article" />
					<meta property="og:image" content="https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post-1000x600.png" />
		<meta name="twitter:image" content="https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post-1000x600.png" />
	<meta property="og:url" content="https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/" />
<meta property="og:title" content="&#8220;Phill The Box&#8221; Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students" />
<meta property="og:description" content="Spring, Texas &#8211; Over the last month, students from Hildebrandt Intermediate have participated in a &#8220;Phill The Box&#8221; fundraiser. Students in business, finance, and marketing classes are amongst those promoting the fundraiser. Also, students in the National Junior Honors Society, STUCO, and PATH programs are active participants. &#8220;Phill The Box&#8221; fundraisers aid local communities by collecting [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/">
<meta name="twitter:title" content="&#8220;Phill The Box&#8221; Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students">
<meta name="twitter:description" content="Spring, Texas &#8211; Over the last month, students from Hildebrandt Intermediate have participated in a &#8220;Phill The Box&#8221; fundraiser. Students in business, finance, and marketing classes are amongst those promoting the fundraiser. Also, students in the National Junior Honors Society, STUCO, and PATH programs are active participants. &#8220;Phill The Box&#8221; fundraisers aid local communities by collecting [&hellip;]">
<script type='text/javascript' src='https://servedbyadbutler.com/hb_app.js' async></script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>&quot;Phill The Box&quot; Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students - Spring Happenings</title>
	<link rel="canonical" href="https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="&quot;Phill The Box&quot; Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students - Spring Happenings" />
	<meta property="og:description" content="Spring, Texas &#8211; Over the last month, students from Hildebrandt Intermediate have participated in a &#8220;Phill The Box&#8221; fundraiser. Students in business, finance, and marketing classes are amongst those promoting the fundraiser. Also, students in the National Junior Honors Society, STUCO, and PATH programs are active participants. &#8220;Phill The Box&#8221; fundraisers aid local communities by collecting [&hellip;]" />
	<meta property="og:url" content="https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/" />
	<meta property="og:site_name" content="Spring Happenings" />
	<meta property="article:publisher" content="https://www.facebook.com/springhappenings/" />
	<meta property="article:published_time" content="2021-03-28T22:37:18+00:00" />
	<meta property="og:image" content="https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post.png" />
	<meta property="og:image:width" content="1452" />
	<meta property="og:image:height" content="778" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Brandon Acosta">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="2 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.springhappenings.com/#website","url":"https://www.springhappenings.com/","name":"Spring Happenings","description":"Spring, Texas News - Community Information, Weather, Traffic","potentialAction":[{"@type":"SearchAction","target":"https://www.springhappenings.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/#primaryimage","inLanguage":"en-US","url":"https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post.png","width":1452,"height":778},{"@type":"WebPage","@id":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/#webpage","url":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/","name":"\"Phill The Box\" Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students - Spring Happenings","isPartOf":{"@id":"https://www.springhappenings.com/#website"},"primaryImageOfPage":{"@id":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/#primaryimage"},"datePublished":"2021-03-28T22:37:18+00:00","dateModified":"2021-03-28T22:37:18+00:00","author":{"@id":"https://www.springhappenings.com/#/schema/person/0628b61a0a13c05b922d189c33a04329"},"breadcrumb":{"@id":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/"]}]},{"@type":"BreadcrumbList","@id":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.springhappenings.com/","url":"https://www.springhappenings.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/","url":"https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/","name":"&#8220;Phill The Box&#8221; Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students"}}]},{"@type":"Person","@id":"https://www.springhappenings.com/#/schema/person/0628b61a0a13c05b922d189c33a04329","name":"Brandon Acosta","image":{"@type":"ImageObject","@id":"https://www.springhappenings.com/#personlogo","inLanguage":"en-US","url":"https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-96x96.jpg","caption":"Brandon Acosta"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<script type='application/javascript'>console.log('PixelYourSite Free version 8.0.9');</script>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Spring Happenings &raquo; Feed" href="https://www.springhappenings.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Spring Happenings &raquo; Comments Feed" href="https://www.springhappenings.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.springhappenings.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='formidable-css'  href='https://www.springhappenings.com/wp-content/plugins/formidable/css/formidableforms.css?ver=325438' type='text/css' media='all' />
<link rel='stylesheet' id='_ning_css-css'  href='https://www.springhappenings.com/wp-content/plugins/angwp/assets/dist/angwp.bundle.js.css?ver=1.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.springhappenings.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.springhappenings.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='_ning_font_awesome_css-css'  href='https://www.springhappenings.com/wp-content/plugins/angwp/assets/fonts/font-awesome/css/font-awesome.min.css?ver=1.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='spr_col_animate_css-css'  href='https://www.springhappenings.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/css/animate.min.css?ver=1.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='spr_col_css-css'  href='https://www.springhappenings.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/css/spr_columns.css?ver=1.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='mailerlite_forms.css-css'  href='https://www.springhappenings.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css'  href='https://www.springhappenings.com/wp-content/themes/zox-news/style.css?ver=5.7' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://www.springhappenings.com/wp-content/themes/zox-news/css/reset.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://www.springhappenings.com/wp-content/themes/zox-news/font-awesome/css/font-awesome.css?ver=5.7' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C700%2C900%7COswald%3A400%2C700%7CAdvent+Pro%3A700%7COpen+Sans%3A700%7CAnton%3A400Oswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://www.springhappenings.com/wp-content/themes/zox-news/css/media-queries.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://www.springhappenings.com/?sccss=1&#038;ver=5.7' type='text/css' media='all' />
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/angwp/assets/dev/js/advertising.js?ver=5.7' id='adning_dummy_advertising-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/pixelyoursite/dist/scripts/jquery.bind-first-0.2.3.min.js?ver=5.7' id='jquery-bind-first-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/pixelyoursite/dist/scripts/js.cookie-2.1.3.min.js?ver=2.1.3' id='js-cookie-js'></script>
<script type='text/javascript' id='pys-js-extra'>
/* <![CDATA[ */
var pysOptions = {"staticEvents":{"facebook":{"PageView":[{"delay":0,"type":"static","name":"PageView","pixelIds":["305130606671684"],"params":{"post_category":"Education, Featured, Harris County","page_title":"\"Phill The Box\" Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students","post_type":"post","post_id":"17319","user_role":"guest","plugin":"PixelYourSite","event_url":"www.springhappenings.com\/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students\/"},"ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}]}},"dynamicEvents":{"signal_form":{"facebook":{"delay":0,"type":"dyn","name":"Signal","pixelIds":["305130606671684"],"params":{"event_action":"Form","page_title":"\"Phill The Box\" Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students","post_type":"post","post_id":"17319","user_role":"guest","plugin":"PixelYourSite","event_url":"www.springhappenings.com\/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students\/"},"ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}},"signal_download":{"facebook":{"delay":0,"type":"dyn","name":"Signal","extensions":["doc","exe","js","pdf","ppt","tgz","zip","xls"],"pixelIds":["305130606671684"],"params":{"event_action":"Download","page_title":"\"Phill The Box\" Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students","post_type":"post","post_id":"17319","user_role":"guest","plugin":"PixelYourSite","event_url":"www.springhappenings.com\/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students\/"},"ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}},"signal_comment":{"facebook":{"delay":0,"type":"dyn","name":"Signal","pixelIds":["305130606671684"],"params":{"event_action":"Comment","page_title":"\"Phill The Box\" Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students","post_type":"post","post_id":"17319","user_role":"guest","plugin":"PixelYourSite","event_url":"www.springhappenings.com\/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students\/"},"ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}}},"triggerEvents":[],"triggerEventTypes":[],"facebook":{"pixelIds":["305130606671684"],"advancedMatching":[],"removeMetadata":false,"contentParams":{"post_type":"post","post_id":17319,"content_name":"\"Phill The Box\" Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students","categories":"Education, Featured, Harris County","tags":""},"commentEventEnabled":true,"wooVariableAsSimple":false,"downloadEnabled":true,"formEventEnabled":true,"ajaxForServerEvent":true,"serverApiEnabled":false,"wooCRSendFromServer":false},"debug":"","siteUrl":"https:\/\/www.springhappenings.com","ajaxUrl":"https:\/\/www.springhappenings.com\/wp-admin\/admin-ajax.php","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":false,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":null,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":null,"cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","real_cookie_banner_integration_enabled":false,"ginger_integration_enabled":false,"cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false},"edd":{"enabled":false},"woo":{"enabled":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/pixelyoursite/dist/scripts/public.js?ver=8.0.9' id='pys-js'></script>
<link rel="https://api.w.org/" href="https://www.springhappenings.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.springhappenings.com/wp-json/wp/v2/posts/17319" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.springhappenings.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.springhappenings.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://www.springhappenings.com/?p=17319' />
<link rel="alternate" type="application/json+oembed" href="https://www.springhappenings.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.springhappenings.com%2Fphill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.springhappenings.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.springhappenings.com%2Fphill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students%2F&#038;format=xml" />

<!--BEGIN: TRACKING CODE MANAGER BY INTELLYWP.COM IN HEAD//-->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-131198477-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-131198477-1');
</script>
<!--END: https://wordpress.org/plugins/tracking-code-manager IN HEAD//--><link rel="amphtml" href="https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/amp/">
<!-- Ads on this site are served by Adning v1.6.0 - adning.com -->
<style></style><!-- / Adning. -->

<link rel="icon" href="https://www.springhappenings.com/wp-content/uploads/2017/12/cropped-14729396_1480267575322310_3796130362041713281_n-1-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.springhappenings.com/wp-content/uploads/2017/12/cropped-14729396_1480267575322310_3796130362041713281_n-1-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.springhappenings.com/wp-content/uploads/2017/12/cropped-14729396_1480267575322310_3796130362041713281_n-1-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.springhappenings.com/wp-content/uploads/2017/12/cropped-14729396_1480267575322310_3796130362041713281_n-1-270x270.jpg" />
		<style type="text/css" id="wp-custom-css">
			#mvp-main-body-wrap {
    padding-bottom: 0px;
    
}
.mvp-nav-links{
	margin-bottom:50px;
}
.click-add img{
	margin-top:50px;
}		</style>
		</head>
<body data-rsssl=1 class="post-template-default single single-post postid-17319 single-format-standard wp-embed-responsive">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="https://www.springhappenings.com/"><img src="https://www.springhappenings.com/wp-content/uploads/2021/02/SH.COM-White.png" alt="Spring Happenings" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-10795" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-10795"><a href="https://www.springhappenings.com">Local News</a></li>
<li id="menu-item-11188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11188"><a href="https://www.springhappenings.com/weather-radar/">Weather &#038; Interactive Radar</a></li>
<li id="menu-item-11320" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11320"><a target="_blank" rel="noopener" href="https://adv-springhappenings.com/get-started">Advertise</a></li>
<li id="menu-item-10631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10631"><a href="https://www.springhappenings.com/contact-us/">Contact us</a></li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/springhappenings" target="_blank" class="fa fa-facebook fa-2"></a></li>
																<li><a href="https://www.instagram.com/springhappenings/" target="_blank" class="fa fa-instagram fa-2"></a></li>
													<li><a href="https://www.youtube.com/channel/UCJfi7NhSOF42wyUfp_9O-cw" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
											</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->	<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="https://www.springhappenings.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
				<div id="mvp-site-wall" class="left relative">
											<div id="mvp-leader-wrap">
					<div style="background-color: black"> 
<!-- Below Header Responsive [javascript] -->
<script type="text/javascript">
var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid429503 = window.pid429503 || rnd;
var plc429503 = window.plc429503 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=168825;size=0x0;setID=429503;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid429503+';place='+(plc429503++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');
</script>
</div>				</div><!--mvp-leader-wrap-->
										<div id="mvp-site-main" class="left relative">
			<header id="mvp-main-head-wrap" class="left relative">
									<nav id="mvp-main-nav-wrap" class="left relative">
						<div id="mvp-main-nav-top" class="left relative">
							<div class="mvp-main-box">
								<div id="mvp-nav-top-wrap" class="left relative">
									<div class="mvp-nav-top-right-out left relative">
										<div class="mvp-nav-top-right-in">
											<div class="mvp-nav-top-cont left relative">
												<div class="mvp-nav-top-left-out relative">
													<div class="mvp-nav-top-left">
														<div class="mvp-nav-soc-wrap">
																															<a href="https://www.facebook.com/springhappenings" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook fa-2"></span></a>
																																																													<a href="https://www.instagram.com/springhappenings/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a>
																																														<a href="https://www.youtube.com/channel/UCJfi7NhSOF42wyUfp_9O-cw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube-play fa-2"></span></a>
																													</div><!--mvp-nav-soc-wrap-->
														<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
															<span></span>
															<span></span>
															<span></span>
															<span></span>
														</div><!--mvp-fly-but-wrap-->
													</div><!--mvp-nav-top-left-->
													<div class="mvp-nav-top-left-in">
														<div class="mvp-nav-top-mid left relative" itemscope itemtype="http://schema.org/Organization">
																															<a class="mvp-nav-logo-reg" itemprop="url" href="https://www.springhappenings.com/"><img itemprop="logo" src="https://www.springhappenings.com/wp-content/uploads/2021/02/SH.COM-White.png" alt="Spring Happenings" data-rjs="2" /></a>
																																														<a class="mvp-nav-logo-small" href="https://www.springhappenings.com/"><img src="https://www.springhappenings.com/wp-content/uploads/2021/02/SH.COM-White.png" alt="Spring Happenings" data-rjs="2" /></a>
																																														<h2 class="mvp-logo-title">Spring Happenings</h2>
																																														<div class="mvp-drop-nav-title left">
																	<h4>&#8220;Phill The Box&#8221; Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students</h4>
																</div><!--mvp-drop-nav-title-->
																													</div><!--mvp-nav-top-mid-->
													</div><!--mvp-nav-top-left-in-->
												</div><!--mvp-nav-top-left-out-->
											</div><!--mvp-nav-top-cont-->
										</div><!--mvp-nav-top-right-in-->
										<div class="mvp-nav-top-right">
																						<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
										</div><!--mvp-nav-top-right-->
									</div><!--mvp-nav-top-right-out-->
								</div><!--mvp-nav-top-wrap-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-top-->
						<div id="mvp-main-nav-bot" class="left relative">
							<div id="mvp-main-nav-bot-cont" class="left">
								<div class="mvp-main-box">
									<div id="mvp-nav-bot-wrap" class="left">
										<div class="mvp-nav-bot-right-out left">
											<div class="mvp-nav-bot-right-in">
												<div class="mvp-nav-bot-cont left">
													<div class="mvp-nav-bot-left-out">
														<div class="mvp-nav-bot-left left relative">
															<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
																<span></span>
																<span></span>
																<span></span>
																<span></span>
															</div><!--mvp-fly-but-wrap-->
														</div><!--mvp-nav-bot-left-->
														<div class="mvp-nav-bot-left-in">
															<div class="mvp-nav-menu left">
																<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-10795"><a href="https://www.springhappenings.com">Local News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11188"><a href="https://www.springhappenings.com/weather-radar/">Weather &#038; Interactive Radar</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11320"><a target="_blank" rel="noopener" href="https://adv-springhappenings.com/get-started">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10631"><a href="https://www.springhappenings.com/contact-us/">Contact us</a></li>
</ul></div>															</div><!--mvp-nav-menu-->
														</div><!--mvp-nav-bot-left-in-->
													</div><!--mvp-nav-bot-left-out-->
												</div><!--mvp-nav-bot-cont-->
											</div><!--mvp-nav-bot-right-in-->
											<div class="mvp-nav-bot-right left relative">
												<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
											</div><!--mvp-nav-bot-right-->
										</div><!--mvp-nav-bot-right-out-->
									</div><!--mvp-nav-bot-wrap-->
								</div><!--mvp-main-nav-bot-cont-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-bot-->
					</nav><!--mvp-main-nav-wrap-->
							</header><!--mvp-main-head-wrap-->
			<div id="mvp-main-body-wrap" class="left relative">	<article id="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
			<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.springhappenings.com/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students/"/>
						<div id="mvp-article-cont" class="left relative">
			<div class="mvp-main-box">
				<div id="mvp-post-main" class="left relative">
										<header id="mvp-post-head" class="left relative">
						<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.springhappenings.com/category/education/"><span class="mvp-post-cat left">Education</span></a></h3>
						<h1 class="mvp-post-title left entry-title" itemprop="headline">&#8220;Phill The Box&#8221; Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students</h1>
																			<div class="mvp-author-info-wrap left relative">
								<div class="mvp-author-info-thumb left relative">
									<img width="46" height="46" src="https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-48x48.jpg" class="avatar avatar-46 photo" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-48x48.jpg 48w, https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-150x150.jpg 150w, https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-300x300.jpg 300w, https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-80x80.jpg 80w, https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-24x24.jpg 24w, https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-96x96.jpg 96w, https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n-50x50.jpg 50w, https://www.springhappenings.com/wp-content/uploads/2019/03/14729396_1480267575322310_3796130362041713281_n.jpg 667w" sizes="(max-width: 46px) 100vw, 46px" />								</div><!--mvp-author-info-thumb-->
								<div class="mvp-author-info-text left relative">
									<div class="mvp-author-info-date left relative">
										<p>Published</p> <span class="mvp-post-date">8 hours ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2021-03-28">March 28, 2021</time></span>
										<meta itemprop="dateModified" content="2021-03-28 5:37 pm"/>
									</div><!--mvp-author-info-date-->
									<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
										<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.springhappenings.com/author/bacosta/" title="Posts by Brandon Acosta" rel="author">Brandon Acosta</a></span> 									</div><!--mvp-author-info-name-->
								</div><!--mvp-author-info-text-->
							</div><!--mvp-author-info-wrap-->
											</header>
										<div class="mvp-post-main-out left relative">
						<div class="mvp-post-main-in">
							<div id="mvp-post-content" class="left relative">
																																																														<div id="mvp-post-feat-img" class="left relative mvp-post-feat-img-wide2" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
												<img width="1452" height="778" src="https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post.png" class="attachment- size- wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post.png 1452w, https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post-300x161.png 300w, https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post-1024x549.png 1024w, https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post-768x412.png 768w" sizes="(max-width: 1452px) 100vw, 1452px" />																								<meta itemprop="url" content="https://www.springhappenings.com/wp-content/uploads/2021/03/Phill-the-Box-featured-post-1000x600.png">
												<meta itemprop="width" content="1000">
												<meta itemprop="height" content="600">
											</div><!--mvp-post-feat-img-->
																							<span class="mvp-feat-caption">Featured Image Credit: Hildebrant Intermediate</span>
																																																														<div id="mvp-content-wrap" class="left relative">
									<div class="mvp-post-soc-out right relative">
																																									<div class="mvp-post-soc-in">
											<div id="mvp-content-body" class="left relative">
												<div id="mvp-content-body-top" class="left relative">
																																							<div id="mvp-content-main" class="left relative">
														<div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- Above Content - Responsive [javascript] -->
<script type="text/javascript">
var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid427252 = window.pid427252 || rnd;
var plc427252 = window.plc427252 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=168825;size=0x0;setID=427252;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid427252+';place='+(plc427252++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');
</script>

<br></div>
<p><em><strong>Spring, Texas &#8211; </strong></em>Over the last month, students from Hildebrandt Intermediate have participated in a &#8220;Phill The Box&#8221; fundraiser. Students in business, finance, and marketing classes are amongst those promoting the fundraiser. Also, students in the National Junior Honors Society, STUCO, and PATH programs are active participants.</p>
<p>&#8220;Phill The Box&#8221; fundraisers aid local communities by collecting gently used clothing, shoes, and household items. The school has set up and decorated three large donation bins to help accommodate the student&#8217;s efforts. Once a month, the &#8220;Phill The Box&#8221; organization will collect the textile donations and turn them into funds which are given directly to the school.</p><div class='code-block code-block-3' style='margin: 0px auto 8px 0px; text-align: center; clear: both; padding-left: 0px; padding-top: 5px; padding-bottom: 15px;'>
<script type="text/javascript">
function loadTextAd(sparkCounter, id, setID) {
  output335663="https://servedbyadbutler.com/adserve/;ID=" + id + ";setID=" + setID + ";type=textad;kw=" + abkw + ";pid=" + rnd + ";layoutID=" + sparkCounter;
  document.writeln("<SCR" + "IPT ASYNC SRC=" + output335663 + " type=\"text/javascript\"><\/scr" + "ipt>");
}
var loadedTextAds335663;
if(loadedTextAds335663 == null)
  loadedTextAds335663= new Array();
var d = new Date();
var id335663 = 168825;
var setID335663 = 335663;
var rnd = window.rnd || Math.floor(Math.random()*10e6);
var abkw = window.abkw ||'';
var sparkCounter335663;
if(sparkCounter335663 == null)
  sparkCounter335663 = 1;
else
  sparkCounter335663 = sparkCounter335663 + 1;
id="abta335663" + sparkCounter335663;
document.writeln("<div id='" + id + "'></div>");
loadedTextAds335663[sparkCounter335663] = false;
loadTextAd(sparkCounter335663, id335663, setID335663);
</script>
</div>

<p>The school&#8217;s students have a goal of donating more than 25,000 pounds of used items. Once complete, the students would set a record for the most successful &#8220;Phill The Box&#8221; fundraiser to date.</p>
<p>All students participating believe their fundraiser will have a long-lasting impact on the Klein community and local environment. Students have placed the donation bins in front of their school&#8217;s gym and are open for donations at any time. Community donations will help the students achieve their goal much faster.</p>
<p>Students attending schools in the surrounding area have started to pitch similar ideas for fundraising. Already, Klein Cain High School has announced a &#8220;Fill the Truck&#8221; fundraiser, similar to Hildebradt&#8217;s efforts.</p>
<p>Klein ISD parents and community members have expressed their gratitude for the fundraiser and support the student&#8217;s efforts to make the community around them a better place.</p>
<p><a href="https://phillthebox.com">Click here to learn more about the Phill The Box organization. </a></p>
<div class='code-block code-block-2' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- Below Content - Responsive [javascript] -->
<script type="text/javascript">
var rnd = window.rnd || Math.floor(Math.random()*10e6);
var pid427254 = window.pid427254 || rnd;
var plc427254 = window.plc427254 || 0;
var abkw = window.abkw || '';
var absrc = 'https://servedbyadbutler.com/adserve/;ID=168825;size=0x0;setID=427254;type=js;sw='+screen.width+';sh='+screen.height+';spr='+window.devicePixelRatio+';kw='+abkw+';pid='+pid427254+';place='+(plc427254++)+';rnd='+rnd+';click=CLICK_MACRO_PLACEHOLDER';
document.write('<scr'+'ipt src="'+absrc+'" type="text/javascript"></scr'+'ipt>');
</script></div>
<!-- AI CONTENT END 4 -->
																											</div><!--mvp-content-main-->
													<div id="mvp-content-bot" class="left">
																												<div class="mvp-post-tags">
															<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"></span>
														</div><!--mvp-post-tags-->
														<div class="posts-nav-link">
																													</div><!--posts-nav-link-->
																													<div id="mvp-prev-next-wrap" class="left relative">
																																																	<div class="mvp-prev-post-wrap left relative">
																		<a href="https://www.springhappenings.com/the-centrum-to-reopen-on-easter-sunday-after-closing-for-nearly-4-years/" rel="bookmark">
																		<div class="mvp-prev-next-cont left relative">
																			<div class="mvp-prev-cont-out right relative">
																				<span class="mvp-prev-arr fa fa-chevron-left left"></span>
																				<div class="mvp-prev-cont-in">
																					<div class="mvp-prev-next-text left relative">
																						<span class="mvp-prev-next-label left relative">Don&#039;t Miss</span>
																						<p>The Centrum to Reopen on Easter Sunday After Closing for Nearly 4 Years</p>
																					</div><!--mvp-prev-next-text-->
																				</div><!--mvp-prev-cont-in-->
																			</div><!--mvp-prev-cont-out-->
																		</div><!--mvp-prev-next-cont-->
																		</a>
																	</div><!--mvp-prev-post-wrap-->
																															</div><!--mvp-prev-next-wrap-->
																																										<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
															<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																																	<img src="https://www.springhappenings.com/wp-content/uploads/2021/02/SH.COM-White.png"/>
																	<meta itemprop="url" content="https://www.springhappenings.com/wp-content/uploads/2021/02/SH.COM-White.png">
																															</div><!--mvp-org-logo-->
															<meta itemprop="name" content="Spring Happenings">
														</div><!--mvp-org-wrap-->
													</div><!--mvp-content-bot-->
												</div><!--mvp-content-body-top-->
												<div class="mvp-cont-read-wrap">
																																																																</div><!--mvp-cont-read-wrap-->
											</div><!--mvp-content-body-->
										</div><!--mvp-post-soc-in-->
									</div><!--mvp-post-soc-out-->
								</div><!--mvp-content-wrap-->
													</div><!--mvp-post-content-->
						</div><!--mvp-post-main-in-->
													<div id="mvp-side-wrap" class="left relative theiaStickySidebar">
						<section id="custom_html-3" class="widget_text mvp-side-widget widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript" src="https://static.mailerlite.com/data/webforms/754814/k9r5d6.js?v3"></script></div></section><section id="adbutler-2" class="mvp-side-widget widget_adbutler"><!-- Sidebox 2 - Responsive [js] -->
        <script type="text/javascript">
            var rnd = window.rnd || Math.floor(Math.random() * 10e6);
            var pid427502 = window.pid427502 || rnd;
            var plc427502 = window.plc427502 || 0;
            var abkw = window.abkw || '';
            var referrer = 'https%3A%2F%2Fwww.springhappenings.com%2Fphill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students%2F';
            var absrc = 'https://servedbyadbutler.com/adserve/;ID=168825;size=0x0;setID=427502;type=js;sw=' + screen.width + ';sh=' + screen.height + ';spr=' + window.devicePixelRatio + ';kw=' + abkw + ';pid=' + pid427502+ ';place=' + (plc427502++) + ';rnd=' + rnd + ';referrer=' + referrer;

            document.write('<scr' + 'ipt src="' + absrc + '" type="text/javascript"></scr' + 'ipt>');
        </script>
        </section><section id="adbutler-6" class="mvp-side-widget widget_adbutler"><!-- Sidebox 1 - Responsive [js] -->
        <script type="text/javascript">
            var rnd = window.rnd || Math.floor(Math.random() * 10e6);
            var pid427500 = window.pid427500 || rnd;
            var plc427500 = window.plc427500 || 0;
            var abkw = window.abkw || '';
            var referrer = 'https%3A%2F%2Fwww.springhappenings.com%2Fphill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students%2F';
            var absrc = 'https://servedbyadbutler.com/adserve/;ID=168825;size=0x0;setID=427500;type=js;sw=' + screen.width + ';sh=' + screen.height + ';spr=' + window.devicePixelRatio + ';kw=' + abkw + ';pid=' + pid427500+ ';place=' + (plc427500++) + ';rnd=' + rnd + ';referrer=' + referrer;

            document.write('<scr' + 'ipt src="' + absrc + '" type="text/javascript"></scr' + 'ipt>');
        </script>
        </section><section id="adbutler-7" class="mvp-side-widget widget_adbutler"><!-- Sidebox 5 - Responsive [js] -->
        <script type="text/javascript">
            var rnd = window.rnd || Math.floor(Math.random() * 10e6);
            var pid444667 = window.pid444667 || rnd;
            var plc444667 = window.plc444667 || 0;
            var abkw = window.abkw || '';
            var referrer = 'https%3A%2F%2Fwww.springhappenings.com%2Fphill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students%2F';
            var absrc = 'https://servedbyadbutler.com/adserve/;ID=168825;size=0x0;setID=444667;type=js;sw=' + screen.width + ';sh=' + screen.height + ';spr=' + window.devicePixelRatio + ';kw=' + abkw + ';pid=' + pid444667+ ';place=' + (plc444667++) + ';rnd=' + rnd + ';referrer=' + referrer;

            document.write('<scr' + 'ipt src="' + absrc + '" type="text/javascript"></scr' + 'ipt>');
        </script>
        </section><section id="text-2" class="mvp-side-widget widget_text"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Disclaimer:</span></h4></div>			<div class="textwidget"><p>All information is deemed reliable, but not guaranteed. Information, reports, releases, and events are subject to change. Any logos or trademarked images are copyright protected by their respective owners. Their use does not imply endorsement of or by this website.</p>
<p>Spring Media, LLC is independently and privately owned. We are not affiliated or endorsed by any government or civic entity, including any City or any other government or administrative organization.</p>
</div>
		</section>			</div><!--mvp-side-wrap-->											</div><!--mvp-post-main-out-->
				</div><!--mvp-post-main-->
							<div id="mvp-post-more-wrap" class="left relative">
					<h4 class="mvp-widget-home-title">
						<span class="mvp-widget-home-title">In Case You Missed It</span>
					</h4>
					<ul class="mvp-post-more-list left relative">
													<a href="https://www.springhappenings.com/two-people-dead-several-others-transported-via-helicopter-after-fiery-crash-on-fm-2920/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="209" src="https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic.png" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic.png 1200w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-300x157.png 300w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-768x402.png 768w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-1024x536.png 1024w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-1000x520.png 1000w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="42" src="https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic.png" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic.png 1200w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-300x157.png 300w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-768x402.png 768w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-1024x536.png 1024w, https://www.springhappenings.com/wp-content/uploads/2019/08/breakingnewsgraphic-1000x520.png 1000w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Fire/EMS</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Two People Dead, Several Others Transported Via Helicopter After Fiery Crash on FM 2920</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.springhappenings.com/suspect-arrested-for-intoxication-manslaughter-after-killing-mother-and-two-children-in-fiery-crash-along-fm-2920/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-400x240.png" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-400x240.png 400w, https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-1000x600.png 1000w, https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-590x354.png 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-80x80.png" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-80x80.png 80w, https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-150x150.png 150w, https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-24x24.png 24w, https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-48x48.png 48w, https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-96x96.png 96w, https://www.springhappenings.com/wp-content/uploads/2021/03/danielcanada2920fatal-300x300.png 300w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Fire/EMS</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Suspect Arrested For Intoxication Manslaughter After Killing Mother and Three Children in Fiery Crash Along FM 2920</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.springhappenings.com/man-airlifted-after-being-beat-with-hammer-at-bridgestone-crossing-townhomes/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.springhappenings.com/wp-content/uploads/2018/11/happeningnow-400x240.png" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2018/11/happeningnow-400x240.png 400w, https://www.springhappenings.com/wp-content/uploads/2018/11/happeningnow-1000x600.png 1000w, https://www.springhappenings.com/wp-content/uploads/2018/11/happeningnow-590x354.png 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.springhappenings.com/wp-content/uploads/2018/11/happeningnow-80x80.png" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2018/11/happeningnow-80x80.png 80w, https://www.springhappenings.com/wp-content/uploads/2018/11/happeningnow-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Crime</span><span class="mvp-cd-date left relative">1 week ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Man Airlifted After Being Beat with Hammer at Bridgestone Crossing Townhomes</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.springhappenings.com/constables-arrest-15-intoxicated-drivers-over-spring-break/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-400x240.png" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-400x240.png 400w, https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-1000x600.png 1000w, https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-590x354.png 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-80x80.png" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-80x80.png 80w, https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-150x150.png 150w, https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-24x24.png 24w, https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-48x48.png 48w, https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-96x96.png 96w, https://www.springhappenings.com/wp-content/uploads/2021/03/2021-spring-break-dwi-arrests2-300x300.png 300w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Crime</span><span class="mvp-cd-date left relative">5 days ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Constables Arrest 15 Intoxicated Drivers Over Spring Break</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
											</ul>
				</div><!--mvp-post-more-wrap-->
						</div><!--mvp-main-box-->
		</div><!--mvp-article-cont-->
		</article><!--mvp-article-wrap-->
			</div><!--mvp-main-body-wrap-->
			<footer id="mvp-foot-wrap" class="left relative">
				<div id="mvp-foot-top" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-logo" class="left relative">
															<a href="https://www.springhappenings.com/"><img src="https://www.springhappenings.com/wp-content/uploads/2021/02/SH.COM-White.png" alt="Spring Happenings" data-rjs="2" /></a>
													</div><!--mvp-foot-logo-->
						<div id="mvp-foot-soc" class="left relative">
							<ul class="mvp-foot-soc-list left relative">
																	<li><a href="https://www.facebook.com/springhappenings" target="_blank" class="fa fa-facebook fa-2"></a></li>
																																									<li><a href="https://www.instagram.com/springhappenings/" target="_blank" class="fa fa-instagram fa-2"></a></li>
																																	<li><a href="https://www.youtube.com/channel/UCJfi7NhSOF42wyUfp_9O-cw" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
																															</ul>
						</div><!--mvp-foot-soc-->
						<div id="mvp-foot-menu-wrap" class="left relative">
							<div id="mvp-foot-menu" class="left relative">
								<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-14051" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14051"><a href="https://www.springhappenings.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-14052" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14052"><a href="https://www.springhappenings.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-15297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15297"><a href="https://www.springhappenings.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-15371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15371"><a href="https://www.springhappenings.com/accessibility/">Accessibility</a></li>
</ul></div>							</div><!--mvp-foot-menu-->
						</div><!--mvp-foot-menu-wrap-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-top-->
				<div id="mvp-foot-bot" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © 2005-2020 Spring Media, LLC / SpringHappenings.com. All rights reserved.
Server Hosted by <a href="http://netdepot.com/">NetDepot.com</a></p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-bot-->
			</footer>
		</div><!--mvp-site-main-->
	</div><!--mvp-site-wall-->
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
<script>function loadScript(a){var b=document.getElementsByTagName("head")[0],c=document.createElement("script");c.type="text/javascript",c.src="https://tracker.metricool.com/app/resources/be.js",c.onreadystatechange=a,c.onload=a,b.appendChild(c)}loadScript(function(){beTracker.t({hash:'e69a5af2619f89e7929098d8f75b7bb7'})})</script><noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=305130606671684&ev=PageView&noscript=1&cd[post_category]=Education%2C+Featured%2C+Harris+County&cd[page_title]=%22Phill+The+Box%22+Fundraiser+Gains+Momentum+Amongst+Hildebrandt+Intermediate+Students&cd[post_type]=post&cd[post_id]=17319&cd[user_role]=guest&cd[plugin]=PixelYourSite&cd[event_url]=www.springhappenings.com%2Fphill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students%2F" alt="facebook_pixel"></noscript>
<script type='text/javascript' id='_ning_global-js-extra'>
/* <![CDATA[ */
var _adn_ = {"ajaxurl":"https:\/\/www.springhappenings.com\/wp-admin\/admin-ajax.php","upload":{"dir":"\/home\/spring\/public_html\/wp-content\/uploads\/angwp\/","src":"https:\/\/www.springhappenings.com\/wp-content\/uploads\/angwp\/"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/angwp/assets/dist/angwp.bundle.js?ver=1.6.0' id='_ning_global-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.5.0' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/adbutler/includes/../js/adbutler_hb_init.js?ver=1.28' id='adbutler_hb_init-js'></script>
<script type='text/javascript' id='adbutler_hb_init-js-after'>
AdButlerHB.timeout = 700;
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/adbutler/includes/../js/adbutler_hb_final.js?ver=1.28' id='adbutler_hb_final-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.12.1' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://www.springhappenings.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/dist/dom-ready.min.js?ver=eb19f7980f0268577acb5c2da5457de3' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/dist/hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/dist/i18n.min.js?ver=db9a9a37da262883343e941c3731bc67' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/dist/a11y.min.js?ver=5e00de7a43b31bbb9eaf685f089a3903' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.12.1' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/js/spr_inViewport.js?ver=1.6.0' id='spr_inViewport_js-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/js/parallax.min.js?ver=1.6.0' id='spr_parallax_js-js'></script>
<script type='text/javascript' id='ufc-frontend-script-js-extra'>
/* <![CDATA[ */
var ufc_frontend_ajax_data = {"ajaxurl":"https:\/\/www.springhappenings.com\/wp-admin\/admin-ajax.php","permalink":"https:\/\/www.springhappenings.com\/phill-the-box-fundraiser-gains-momentum-amongst-hildebrandt-intermediate-students\/","title":"\u201cPhill The Box\u201d Fundraiser Gains Momentum Amongst Hildebrandt Intermediate Students","postid":"17319","security":"874ac58614","version":"1.4.6"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/ultimate-facebook-comments/public/js/frontend.min.js?ver=1.4.6' id='ufc-frontend-script-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/themes/zox-news/js/mvpcustom.js?ver=5.7' id='mvp-custom-js'></script>
<script type='text/javascript' id='mvp-custom-js-after'>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</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/themes/zox-news/js/scripts.js?ver=5.7' id='zoxnews-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/themes/zox-news/js/retina.js?ver=5.7' id='retina-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/themes/zox-news/js/flexslider.js?ver=5.7' id='flexslider-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/comment-reply.min.js?ver=5.7' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/js/jquery.validate.min.js?ver=5.7' id='jquery-validation-plugin-js'></script>
<script type='text/javascript' id='strack_js-js-extra'>
/* <![CDATA[ */
var sTrackStatsArgs = {"ajaxurl":"https:\/\/www.springhappenings.com\/wp-admin\/admin-ajax.php","is_admin":"","id":"","track_id":"","content_id":"17319"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-content/plugins/smartrack/public/assets/js/sTrackStats.js?ver=5.7' id='strack_js-js'></script>
<script type='text/javascript' src='https://www.springhappenings.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>

<!-- Ads on this site are served by Adning v1.6.0 - adning.com -->
<!-- / Adning. -->

</body>
</html>
<!-- Page uncached by LiteSpeed Cache 3.6.4 on 2021-03-29 01:55:13 -->